Wednesday, December 22, 2010

Flash upgrade errors

Sometimes the simplest of programs can cause the biggest problems. On a few machines we keep seeing that Flash fails to install. If we login to the machine and install the update via the Web then it will install and report correctly in the browser. I have found that it creates another problem. The MSI that is used to distribute Flash is smart enough to know that there is a problem. On several machines the MSI install log looks like this

MSI (s) (5C:64) [10:12:06:420]: Product: Adobe Flash Player 10 ActiveX -- Configuration failed.

Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.
If you look at Add/Remove programs of the client or if you look at the Resource Explorer of the console you will see a problem:

Here is you see there are multiple versions of Flash installed. To correct this problem we need to remove all copies of Flash from the registry and then allow ConfigMgr to install Flash.



Once all the other versions are removed from the registry the advertisment will try again and it will install. The problem on the client side is that it says it cannot remote the previous version of flash. Something happens at the install that it leaves the older version then at one point the newest version wants to uninstall the old version and it fails. Instead of installing the newest version it fails and then the admin needs to fix the problem. I have had limited success with the Flash uninstaller and trying to remove Flash from Add remove programs doesn’t seem to work.

Many times on reports it only shows one version of flash but looking at Add/remove on the client and in the console we can see multiple because the GUIDS for each application are different.

Now that all the problematic versions are remove it should install flash and show up in the reports correctly

Thursday, December 16, 2010

Forefront Endpoint Protection 2010!

It's here FEP 2010 is now RTM!

Microsoft Volume Licensing Service Center (VLSC) starting Jan. 1, 2010. It is already on Technet and trial versions are out for you to try. This has been a year in the making and looks to be a good addition to Configuration Manager 2007. Now you have secure the desktop right from ConfigMgr (SCCM).

Read the full Annoucment here:

Thursday, December 9, 2010

SQL 2008 SP2 Support

I am sure many people have all been using it but it is now official that SQL 2008 SP2 is now supported on ConfigMgr 2007. According to Harini Muralidharan, Microsoft statement:

"System Center Configuration Manager 2007 SP1, SP2 and R2 now support Microsoft SQL Server 2008 SP2 as a Configuration Manager 2007 site database. The site system role of Reporting Services Point and the client status reporting feature of System Center Configuration Manager 2007 R2 are supported."

No updates are required to use it.

That being said many times people assume that they can just jump to the latest version of SQL or server platform. This is not always the case. The different product groups must test the new platforms to make sure they work correctly and stable with SCCM. Manytimes there might be a patch that needs to be install or a hotfix. As a general rule you can expect a notification from Microsoft no less than 90 Days after something like this happens. So while you can install it in your test enviroment you really should way the 90+ days for the product group to OK it. This will cause less Support calls to Microsoft and problems in your hiearchy.